Errors trying to setup local webiny environment

Hello everyone,

I am trying to setup webiny for the first time.

I am following the quickstart guide on docs.webiny.com

I have set up everything up to step 5 where you deploy your admin api. When I run yarn start in /apps/admin the command finished successfully but when I visit localhost:3001 I get an error that the API is not available.

When I try visiting the graphql API url (https://dthmen1rx4jx2.cloudfront.net/graphql) I get an internal server error (even after waiting for 30+ minutes and confirming that in CloudFront the status is deployed.

I changed the MONGODB_SERVER value to this mongodb+srv://<myuser>:<mypassword>@webiny-test-uwabx.mongodb.net (hid the real user and password) before running webiny deploy-api.

I am running node version 10.14.0 through nvm.
My version of webiny is 2.5.2.

I have been trying to get this thing working all day and would be greatful for any support.

Please let me know if there is anything else I should mention.

Hi @egrechko

Latest node version is 13.6 and LTS is 12.14.1. Can you update it, create new webiny project, deploy it and check the graphql again?

Just by curiosity I’ve created new webiny project on my laptop and deployed api on AWS to make sure that latest webiny release works well. My graphql is accessible.

os: MacOS Catalina 10.15.2
node: 13.6
npm: 6.13.4
webiny cli: 2.5.2

1 Like

Wow, I wasn’t expecting a reply that fast! Thank you.

I changed my node version to 13.6.0 and everything ended up working on the first try.

I’m going to note my previous setups below in case someone else runs into this issue.

Running Ubuntu 18.04 (w/ ipv6 disabled)

Setup 1: Not Working

  • Node 12.14.1
  • NPM 6.13.4
  • Yarn 1.21.1

Setup 2: Not Working

  • Node 10.14.0
  • NPM 6.4.1
  • Yarn 1.21.1

Setup 3: Working

  • Node 13.6.0
  • NPM 6.13.4
  • Yarn 1.21.1

I’m unsure why both node 10.14.0 and 12.14.1 (lts) didn’t seem to work.

Is this a common issue if people try using the LTS version of node?

Maybe the the documentation should be updated to encourage the use of the latest version of node?

Interesting observation. Looks like Webiny uses features available in the latest version of node. As I’m just a hobbyist who’s breaking things up and try to figure out how to fix it I have nothing to do with development. Maybe someone who works closer to the code can shed some light about backward compatibility with earlier versions of node.

Okay so I am able to get the webiny admin working but now I’m running into an issue trying to get the site to work.

Using the node 13.6.0 working setup.

Steps:
cd apps/site
yarn start

Yarn runs successfully but when I view the page in the browser all I get is “An error occurred.”

Any thoughts on what could be the problem?

Did you do

cd apps/admin
yarn start

and went through the installation wizard on your web browser? You won’t be able to start the site if you didn’t finish the wizard.

Yeah I did run yarn start in apps/admin. I left it running as well after finishing the installation wizard.

Here is a screenshot.

Hey guys, just to clarify that Webiny uses @babel/preset-env targetting node v8.10 and greater. I myself am using node v10.14.0 on Windows.

We will soon setup a CI environment to test the entire setup on multiple versions of node so hopefully we’ll be able to find the issue.

Regarding the An error occurred error, unfortunately it requires going into AWS console, and looking at site and ssr lambdas CloudWatch logs.

Please let me know if you have any more problems/questions.

Hey Pavel,

I checked my CloudWatch and Lambda functions and could not find any site or ssr functions.

Here is a screenshot of the functions I have.

Does this look correct or is something missing?

I’m going to try creating a new project inside of WSL to see if maybe the problem is isolated to my Ubuntu 18.04 install.

Thank you for your help.

Ah man sorry, you’re talking about localhost not the deployed app. Even better; once you open your localhost site, open dev tools and check the network tab for GraphQL API calls, see if there is an error in any of them.

If you want you can also join us on Gitter for direct chat: https://gitter.im/Webiny/webiny-js

I setup Webiny on a work computer and ran into the same issue. This time I am accessing the development environment from a remote IP 10.0.0.100.

Otherwise the setup is as follows

  • Node 12.14.1
  • Ubuntu 16.04
  • Webiny 2.6.0

webiny depoly-api worked as expected
yarn start in apps/admin worked and finished installation, kept the admin section running in another tab.
yarn start in apps/site runs successfully but am running into An error occurred again.

I checked out the requests in chrome dev tools and found the error.
Here is the link to the pastebin:
https://pastebin.com/E1KVTDp6

The error message is

"message":"PbPage.findByIds is not a function"

Looks like its related to the page builder.

I also noticed that when I’m in the admin->page builder and click on the Welcome to Webiny page I get an error of TypeError: Cannot read property 'pageBuilder' of undefined. Could the two be related?

Yep, definitely related. Thanks for the detailed report. I’ll try setting up everything from scratch and let you know how it goes.

Thank you for the report and I’m sorry you had to experience this.
The issue is unfortunately related to the recent changes in the commodo library.

But we are planning to do a larger release tomorrow/Thursday, and with it, everything will work as expected I assure you. Additionally, our next step is implementing automated testing, and that will ensure these kind of issues do not repeat.

I will update you as soon as this gets resolved!

Hi @egrechko, I actually released a fix just now.

Please run yarn upgrade @commodo in your project (this is where the bug was present), and after that, completely deploy the API, via webiny deploy-api.

Let me know if you’ll have any other questions.

Hey @Adrian_Smijulj,

Thank you for the fix. I was able to get the site section to work now.

I did run into another issue but this time with the page builder. I am unable to add new blocks to pages. I can however edit and move around existing blocks.

I can also add new pages but cannot add blocks to those pages.

Here is a screenshot (when I hover over the box I don’t get a green plus)

Here is a screenshot of the AddBlock inside React Dev Tools. Looks like it renders in the top left corner.

The form builder does work. I am able to build forms with zero issues.

Do you know how I would go about diagnosing the issue?

Wow great job @egrechko, thanks a lot!

When you hover over a block, it should not look like that, it should have a big Click to Add button. Very weird… Even weirder is that everything works correctly on my setup here.

This is Chrome on Windows right? I guess @pavel could try to do the same thing on his Windows PC?

Hey Adrian,

I gave webiny a break to see if the problem resolves itself in a future update and looks like its been taken care of.

I just started a development site and everything worked out of the box right away.

Thank you for your help.

2 Likes

I have a similar error. When the “webiny deploy-api” command is executed, the webiny.js file is opened in notepad.

os: Windows 10 x64
node: 13.9.0
npm: 6.14.2
yarn: 1.22.0

Hi @Konstantin_Karlovich! This is most likely happening because you have a file association for all your .js files to be opened in notepad. Since there is a webiny.js file in the root of the project, it opens that because he thinks that’s what you want.

I also work on Windows 10, and I don’t have any file associations, and webiny command is working fine.

EDIT:
btw. I’m using Git Bash as my terminal; maybe that is also relevant.