Error when creating new project

Hi,

I am new to webiny. I followed the steps to setup Webiny. When I tried to create new-project. got below error. Please advise.
[[email protected] ~]$ npx create-webiny-project tushinde
npx: installed 208 in 9.312s
Creating project at /home/ec2-user/tushinde:
:heavy_check_mark: Pre-template setup
:heavy_check_mark: Install template package
:heavy_check_mark: Create project folders
:heavy_check_mark: Set up project dependencies
↓ Initialize git [skipped]
→ Git repo not initialized
:heavy_check_mark: Get proper package versions
:heavy_check_mark: Resolve packages
:heavy_check_mark: Install dependencies
:heavy_multiplication_x: Run template-specific actions
→ spawnSync git ENOENT

ERROR OUTPUT:
----------------------------------------
Command failed with ENOENT: git add .gitignore
spawnSync git ENOENT
----------------------------------------

Please open an issue including the error output at https://github.com/webiny/webiny-js/issues/new.

Regards,

Anish

Hi,

Managed to install in Macbook. But now getting below error

yarn webiny deploy api --env=local

yarn run v1.22.10

$ /Users/anishxavier/tushinde/node_modules/.bin/webiny deploy api --env=local

This is the first deploy of local environment, so it may take a few minutes.

:bulb: No environments were found in /.env.json. Skipping.

:bulb: Loaded local environment from /api/.env.json.

:rotating_light: Layer webiny-v4-sharp is not available in undefined region.

error Command failed with exit code 1.

info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.

Regards,

Anish

Hi,

Managed to fix the issue. It was a simple type in .env.json

Regards,

Anish

1 Like