Developer setup


#1

Hi,

What is the procedure to make the developer setup?

The tutorial in the following page uses webiny cli approach.


wondering, if that can be used for running developer branch code as well…

thanks,
MJ.


#2

Hi @MJain

we published a new setup guide for developers earlier today. You can find the new article on https://docs.webiny.com This guide should be enough to create a local dev environment. If you do find some parts not clear enough, please let me know as it’s a “fresh” article, so we are looking for feedback.

New tutorials and articles will be published daily in the upcoming weeks.

Cheers,
Sven


#3

@Sven , thanks. Shall try this out. :+1:


#4

I’m excited for the new articles. I’ve been trying to follow the installation instructions, but running webiny deploy-api I just get “‘module’ is undefined”. I’m not really sure if I’m missing a step.

I also noticed the tutorial says Once your project is created, the last thing you need is configure the database.

but then mentions you need AWS to finish setting it up. Is that step required for local development? I wasn’t sure if that was just the S3_BUCKET field, or if it needs to be configured somewhere else too.


#5

@btcain Could you please post either the full error message, or the screenshot?

Regarding AWS: you need a working AWS account, even for local development, because you need to deploy an API to link it with the React app.


#6

Here you go.

Edit:
I just switched over to my linux partition to give it a try, and didn’t get the same error. Now I’m getting the CredentialsError, which i’m assuming is my S3_Bucket info


#7

Hello,
I am a bit noobing around here and am stuck here:

http://localhost:3001/
Network error

Your API seems to be unavailable!
Make sure your API is available at https://d3j1k472r1xss2.cloudfront.net/graphql

I have 2 buckets in s3:
webiny-files-c9799463: which is empty
webiny-serverless-page-builder-c9799463: which has 1 file called page_builder_installation_files.zip
The buckets are not public.

Config .env.json

I have setup mongodb on atlas and replaced:
"MONGODB_SERVER": "mongodb+srv://myuser:[email protected]",
I am not sure why the AWS buckets could be created. When did I enter the credentials? I am not sure I did that actually. Maybe my aws cli has a few too many rights…
Do I need to replace “JWT_SECRET”: with anything?

tl;dr: initial setup docu can use a little bit more detail.


#8

Hi, I ran into that problem too, but I didn’t see the link about setting up my aws credentials. You can follow the instructions in this video to set up your credentials. Let me know if it doesn’t work. I had to completely erase everything and start over which was an involved process, but I can document it for you if you try this first and it doesn’t work. So make sure your credentials are set up properly and run webiny deploy-api again.