CredentialsError: Missing credentials in config


#1

hello.
I get this when I try to deploy (Error: Missing credentials in config)

Any one can tell me witch command to run to configure my AWS credential.
PS.
I did wached the video that was recomended but it did not help me. I run the same command and it did not work.
Thanks


#2

@Flexo “Missing credentials” means your AWS credentials are not configured. It’s actually an error from AWS SDK. Make sure your credentials work by running “aws sts get-caller-identity”. All the details are in our docs in the quick start section.

If you still have problems with this, let me know. And you can also join our Gitter https://gitter.im/Webiny/webiny-js for faster communication :slight_smile:


#3

Continuing the discussion from CredentialsError: Missing credentials in config:

Hello Pavel, thank you for help. I run (aws sts get-caller-identity)
and I get (-bash: aws: command not found) i have deleted my aws user 3 times and tried agin with new credentials, but still the same issue!?
I stared to install and try webiny for 4 weeks ago and still havent tryed out yet :smiley:

I will join gitter, agin thank you help.


#4

aws: command not found means you don’t even have AWS CLI on your machine. So begin with installing the CLI: https://aws.amazon.com/cli/. Once you have that, you can validate your credentials using aws sts get-caller-identity.


#5

Hi, now I have set up aws cli and run the command line (aws sts get-caller-identity)
it sendes back information such as id.